HR - Hero Time Clock App

Incident Report for EmploymentHero

Resolved

This incident has been resolved.

Thank you.
Posted Nov 12, 2025 - 19:45 AEDT

Identified

Our engineers have identified the root cause and are currently working to resolve.
Posted Nov 12, 2025 - 19:25 AEDT

Investigating

Our engineers are currently investigating an issue causing the Hero Time Clock app to hang at the loading screen for kiosk users.

Thank you for your patience.
Posted Nov 12, 2025 - 19:00 AEDT
This incident affected: HR Software.