Work App - Partially unavailable for some users

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 04:53 AEST

Identified

We’re fixing an issue in the EH Work app that might cause a white screen or trouble switching orgs for some users on version 2.55.2. Thanks for your patience - things will be back to normal soon!
Posted Jun 26, 2025 - 08:21 AEST
This incident affected: HR Software.