Problems related to Pay Runs

Incident Report for EmploymentHero

Resolved

This incident has been resolved.

We apologise for any inconvenience caused.
Posted Sep 02, 2026 - 16:37 AEST

Monitoring

The issue has been fixed and we are now monitoring.
Posted Sep 02, 2026 - 12:05 AEST

Investigating

Hi there. We are currently experiencing an issue that prevents removing employees from a pay run. If you have tried deleting the pay run as a workaround, you may also be seeing an error with that. Our team is actively working on a fix and has already made progress. A resolution is being rolled out now and things should be back to normal soon.

. We are aware of issues with not being able to remove employee from a pay run
. Unable to delete pay run
. Unable to finalise pay run
. Unable to adjust leave
Posted Sep 02, 2026 - 12:00 AEST
This incident affected: Payroll Software - Australia (Create Pay Run), Payroll Software - New Zealand (Create Pay Run), Payroll Software - Malaysia (Create Pay Run), Payroll Software - Singapore (Create Pay Run), and Payroll Software - United Kingdom (Create Pay Run).