HR - Platform Outage

Incident Report for EmploymentHero

Resolved

This incident has been resolved.

Thank you for your patience.
Posted May 08, 2026 - 19:33 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 22:53 AEST

Update

We are continuing to work on a fix for this issue.
Posted May 07, 2026 - 20:41 AEST

Update

We are now experiencing a system outage and our engineers are working to rectify ASAP.
Posted May 07, 2026 - 20:33 AEST

Identified

Issue identified, engineers are applying a fix
Posted May 07, 2026 - 18:56 AEST

Investigating

We are currently investigating and issue with system performance across our platform. Our Engineers are investigating.
Posted May 07, 2026 - 18:48 AEST
This incident affected: HR Software.