HR > Payroll sync impacting expenses.

Incident Report for EmploymentHero

Resolved

Monitoring has confirmed this issue was resolved.
Posted Apr 08, 2026 - 07:31 AEST

Monitoring

This issue has been mitigated and is currently being monitored.
Posted Apr 07, 2026 - 18:19 AEST

Update

Our engineers are still working to identify the cause of this issue.

Thank you.
Posted Apr 07, 2026 - 17:49 AEST

Investigating

Our engineers are currently investigating an issue preventing the sync of timesheets between HR and EH payroll for some customers.

Thank you for your patience.
Posted Apr 07, 2026 - 17:28 AEST
This incident affected: HR Software.