Payroll - Platform Slowness

Incident Report for EmploymentHero

Resolved

This issue has been resolved.

We apologise for any inconvenience caused.
Posted Mar 18, 2025 - 15:05 AEDT

Identified

Our engineers report that we are experiencing another spike of performance degradation.

Investigations are ongoing, thank you for your continued patience.
Posted Mar 18, 2025 - 14:16 AEDT

Monitoring

Payroll platform performance has been restored.

Our engineers are continuing to monitor.
Posted Mar 18, 2025 - 13:35 AEDT

Investigating

The payroll platform is currently experiencing degraded performance.

Our engineers are investigating urgently.

Thank you for your patience.
Posted Mar 18, 2025 - 13:20 AEDT