Managers/Admins not able to create timesheets on behalf of employees

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 11:18 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 18, 2026 - 10:45 AEST

Investigating

We are currently investigating an issue that prevents Managers, Admins, and Owners from creating timesheets on behalf of their direct reports.

Workaround: Direct employee timesheet creation remains fully operational. Employees can submit their own timesheets via web or the mobile app as normal.

Our engineering team is actively working on a fix. We will post additional updates here as soon as new details are available.
Posted Aug 18, 2026 - 10:08 AEST
This incident affected: HR Software.