A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 14:16 AEST
Update
We have implemented a fix for one identified issue and are seeing initial signs of recovery. Our team continues to investigate and address additional contributing factors to ensure full stability.
Posted May 01, 2026 - 12:24 AEST
Identified
We have found some likely causes and are working to address these as soon as possible.
Posted Apr 30, 2026 - 13:54 AEST
Update
We are continuing to investigate this issue.
Posted Apr 30, 2026 - 12:31 AEST
Update
We are continuing to investigate this issue.
Posted Apr 30, 2026 - 07:52 AEST
Update
We are continuing to investigate this issue.
Posted Apr 30, 2026 - 07:39 AEST
Investigating
We are aware of slow performance across the payroll platform. Users may experience significant slowness or general service degradation. Our technical team is investigating, and we will provide updates as they become available.
Posted Apr 29, 2026 - 17:55 AEST
Identified
We are aware of slow performance across the payroll platform. Users may experience significant slowness or general service degradation. Our technical team is investigating, and we will provide updates as they become available.