Intermittent issues with Payroll Services

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 23:53 AEST

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 23:52 AEST

Monitoring

This incident has been resolved
Posted Jun 12, 2025 - 14:09 AEST

Investigating

We've addressed an incident that was impacting some users' access to pay run screens. Services are recovering, and we're continuing to monitor.
Posted Jun 12, 2025 - 13:35 AEST
This incident affected: Payroll Software - Australia (Create Pay Run, Finalise Pay Run), Payroll Software - New Zealand (Create Pay Run, Finalise Pay Run), Payroll Software - Malaysia (Create Pay Run, Finalise Pay Run), Payroll Software - Singapore (Create Pay Run, Finalise Pay Run), and Payroll Software - United Kingdom (Create Pay Run, Finalise Pay Run).