Intermittent issues with Payrun performance.

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 17:10 AEST

Monitoring

The database issues causing these problems appear to be resolved. We are now in a monitoring phase.
Posted Jul 09, 2025 - 15:51 AEST

Investigating

We are currently investigating an intermittent issue within payruns. At the moment, creating, deleting or modifying pay runs can fail.

An update will follow shortly.
Posted Jul 09, 2025 - 15:43 AEST
This incident affected: Payroll Software - Australia (Create Pay Run, Finalise Pay Run).