HR - HR system notifications not sending

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 14:22 AEST

Update

The majority of the backlogged notifications have now processed, though customers may continue to experience a small delay whilst our engineers continue to address root cause.

Thank you for your patience.
Posted Jun 01, 2026 - 13:56 AEST

Investigating

Our engineers are currently investigating an issue impacting HR platform notifications including:

- Password resets
- Invitations
- Workflows
- Payroll admin notifications

We apologise for the inconvenience.
Posted Jun 01, 2026 - 11:30 AEST
This incident affected: HR Software.