HR - Timesheet editing - erroring under certain scenarios.

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 19:43 AEDT

Update

This issue has been resolved.

Thank you.
Posted Feb 24, 2026 - 19:43 AEDT

Update

Our engineers are still in the process of deploying the fix. Apologies for the delay.
Posted Feb 24, 2026 - 19:16 AEDT

Investigating

Some customers may receive an error when editing timesheets through the timesheet management page.

Our engineers have identified the cause and a fix is expected within the hour.

Thank you for your patience.
Posted Feb 24, 2026 - 18:07 AEDT
This incident affected: HR Software.