PY Platform Degraded Performance

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 17:11 AEST

Update

The intermittent performance degradation, which affected pay run screen loading, has been mitigated. All services are operating normally.
Posted Jun 17, 2025 - 09:30 AEST

Identified

We are experiencing slowness but have seen things improve
Posted Jun 16, 2025 - 12:00 AEST

Investigating

The payroll platform is currently experiencing degraded performance.

Our engineers are investigating urgently.

Thank you for your patience.
Posted Jun 16, 2025 - 11:35 AEST
This incident affected: Payroll Software - Australia (Login, Create Pay Run, Finalise Pay Run, Create Employee).