Certifications Upload Error

Incident Report for EmploymentHero

Resolved

The certifications incident is now back to normal and is fully operational.
Posted Jul 09, 2025 - 13:32 AEST

Identified

We have identified an issue with uploading of Certifications in the HR platform. We are aware of this issue and are working on a fix.
Posted Jul 07, 2025 - 10:15 AEST
This incident affected: HR Software.