PY Platform Degraded Performance

Incident Report for EmploymentHero

Resolved

This incident has been resolved.

Thankyou for your patience whilst we investigated
Posted Mar 20, 2025 - 06:33 AEDT

Update

We are continuing to investigate this issue.
Posted Mar 20, 2025 - 03:40 AEDT

Investigating

You may experience delays to background tasks which include creating and finalising pay runs, generating report packs, and clocking in or out.

Our engineers are investigating urgently.

Thank you for your patience.
Posted Mar 20, 2025 - 03:39 AEDT
This incident affected: Payroll Software - United Kingdom (Login, Create Pay Run, Finalise Pay Run, Create Employee).