Missing breaks

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 04:54 AEST

Investigating

We are aware of an issue where in some cases, when a staff member submits a timesheet, the breaks associated with that timesheet are missing.

More information will follow.
Posted Jun 24, 2025 - 17:48 AEST
This incident affected: HR Software.