EH Website Accessibility Issues Due to Cloudflare Outage

Incident Report for EmploymentHero

Monitoring

Cloudflare has now resolved the issue on their end, and our website is back online.

We’ll continue to monitor things closely for the time being to ensure everything remains stable. Thanks so much for your patience while this was being worked through!
Posted Jun 13, 2025 - 06:21 AEST

Investigating

We’re currently experiencing an outage impacting access to our website, due to a broader issue with Cloudflare - a third-party provider that supports our infrastructure.

This may prevent you from accessing certain pages or features on our site. We're closely monitoring the situation and will provide updates as more information becomes available.

Thank you for your patience and understanding - we’ll keep you updated here.
Posted Jun 13, 2025 - 05:24 AEST
This incident affects: Employment Hero Website.