HR - Degraded Performance

Incident Report for EmploymentHero

Resolved

Our engineers have confirmed this issue is resolved.

Thank you.
Posted Feb 05, 2026 - 18:17 AEDT

Identified

Our monitoring shows this issue has returned, investigations are continuing.
Posted Feb 05, 2026 - 18:08 AEDT

Monitoring

Our engineers have identified and resolved the issue and service is in the process of recovering.

We are continuing to monitor.
Posted Feb 05, 2026 - 18:00 AEDT

Investigating

Our engineers are investigating the cause of the HR platform slowness.

Thank you for your patience.
Posted Feb 05, 2026 - 17:35 AEDT
This incident affected: HR Software.