HR - Time off page is currently not loading

Incident Report for EmploymentHero

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 04:02 AEDT

Update

We are currently investigating this issue. This is impacting some users who are accessing the Time Off page in HR.

In the interim all leave can still be submitted and approved via the "My time off page" and via the EH mobile app
Posted Jan 15, 2026 - 01:49 AEDT

Investigating

We are urgently investigating this issue
Posted Jan 15, 2026 - 01:40 AEDT
This incident affected: HR Software.