HR - Some customers may receive an error when accessing the HR platform.
Incident Report for EmploymentHero
Resolved
Our engineers have resolved this issue.

Thank you.
Posted Nov 08, 2024 - 09:47 AEDT
Investigating
Our engineers are aware of reports of a small number of customers receiving an error when accessing the HR platform.

Whilst we address the issue, impacted customers may access the platform using an alternate internet connection (for example their mobile hotspot)

Thank you for your patience.
Posted Nov 07, 2024 - 15:33 AEDT